Our Travel Card is down 😭
Incident Report for Lunar
Resolved
Everything is back to normal - go swipe that card 💸
Posted Sep 13, 2019 - 14:31 CEST
Update
We are continuing to investigate this issue.
Posted Sep 13, 2019 - 14:12 CEST
Investigating
Unfortunately, it's not possible to use your Travel Card at the moment. However, you can still use your Black Card 💳 We apologize for the inconvenience, and we'll keep posting information on this site.
Posted Sep 13, 2019 - 14:11 CEST
This incident affected: 💳 Prepaid Card (✈️ Travel Card).