Payments is down
Incident Report for Lunar Way
Resolved
Phew, just a short time - thank you for your patience 🙏 Hope you had a nice talk with our support, those of you who needed it 🙆‍♀️
Posted 8 months ago. Mar 28, 2018 - 15:59 CEST
Investigating
Unfortunately it is not possible to make payments in the app at the moment 😢

Don't you worry - we have you covered. 👊
Do you have a payment form? - send it through PayMyBill
Do you need to transfer? Write a note and send it through PayMyBill or write our sweet support in the chat, they will help you make the transfer.

Your Lunar Way Visa or Travel Card is still working.
Posted 8 months ago. Mar 28, 2018 - 15:13 CEST