Mastercard is not working 😩
Incident Report for Lunar Way
Resolved
The problem has been resolved and we are keeping an eye on everything πŸ‘€πŸ€ž
Posted about 2 months ago. Jul 26, 2019 - 15:06 CEST
Investigating
Unfortunately, it is not possible to use your Mastercard at the moment πŸ’³ We apologize for the inconvenience. We will keep on posting information on this site
Posted about 2 months ago. Jul 26, 2019 - 14:49 CEST
This incident affected: πŸ’³ Prepaid Card (✈️ Travel Card, πŸ’Ό Business Card Transactions, πŸ‡ΈπŸ‡ͺ Card Transactions Sweden, πŸ‡³πŸ‡΄ Card Transactions Norway).