Card is not working 😫
Incident Report for Lunar Way
Resolved
We have been informed that a solution now has been deployed and we are seeing transactions going through again πŸ’³πŸ’Έ
This issue has been very frustrating for everyone and we are very sorry for any inconvenience. We are doing everything we can to ensure it will not happen again πŸ™
Posted 2 months ago. Feb 20, 2019 - 21:54 CET
Update
Unfortunately no update on this issue 😒 We'll keep pushing everywhere we can and hopefully we are soon able to get you some good news πŸ™
Posted 2 months ago. Feb 19, 2019 - 19:26 CET
Investigating
Unfortunately the card is not working at the moment. 😒
We're investigating the error and promise to keep you updated as soon as we have anything for you guys.
We are so sorry πŸ™
Posted 2 months ago. Feb 19, 2019 - 12:20 CET
This incident affected: πŸ‡ΈπŸ‡ͺ Card Transactions Sweden.