Our Visa card is having some problems 😫
Incident Report for Lunar
Resolved
We are closing this issue for now. We'll handle all the faulty reservations you've notified us about as soon as possible in the morning. Please contact us Tuesday if you are still seeing faulty reservations caused by this problem.
Posted Dec 08, 2019 - 23:10 CET
Investigating
We are currently experiencing some problems with our Visa card - making it is impossible to use the card for some customers. 😔 💳 If you experience any faulty reservations your card please contact us and we'll be sure to handle it tomorrow.
We're very sorry for the inconvenience. Stay tuned on this site for more information.
Posted Dec 08, 2019 - 17:47 CET
This incident affected: 💳 Visa Card Transactions Denmark.