Our Visa card is having some problems 😫
Incident Report for Lunar
Resolved
The problem is fixed - everything is back to normal. Yay! 🎉
Posted Dec 18, 2019 - 20:09 CET
Monitoring
The problem looks as if it has been resolved, and we are keeping an eye on everything. 👀🤞
Posted Dec 18, 2019 - 19:33 CET
Investigating
We are currently experiencing some problems with our Visa card - making it is impossible to use the card. 😔 💳
We're very sorry for the inconvenience. Stay tuned on this site for more information.
Posted Dec 18, 2019 - 18:24 CET
This incident affected: 💳 Visa Card Transactions Denmark.