Problems with Visa card transactions
Incident Report for Lunar Way
Resolved
Everything should now be back to normal 👍
Posted 7 days ago. Mar 14, 2019 - 13:35 CET
Investigating
Nets is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
Posted 8 days ago. Mar 14, 2019 - 12:27 CET
This incident affected: 💳 Card Transactions.