Our Travel Card is down 😭
Incident Report for Lunar
Resolved
Everything is back to normal - go swipe that card 💸
Posted Aug 15, 2019 - 11:03 CEST
Monitoring
The problem has been solved and we are keeping an eye on everything. 👀🤞
Posted Aug 15, 2019 - 10:36 CEST
Investigating
Unfortunately, it's not possible to use your Travel Card at the moment. However, you can still use your Black Card 💳 We apologize for the inconvenience, and we'll keep posting information on this site.
Posted Aug 15, 2019 - 10:02 CEST
This incident affected: 💳 Prepaid Card (✈️ Travel Card).