Lunar Way is down 😢
Incident Report for Lunar Way
Resolved
Everything is back to normal - even though it was a short time, we're still sorry it happened 🙏 Thank you for your patience.
Posted 8 months ago. Mar 19, 2018 - 11:22 CET
Investigating
Sorry guys!
We're having technical problems. We promise that we are working as hard as we can and will keep you updated 🙏
Posted 8 months ago. Mar 19, 2018 - 10:59 CET