Our Visa card is having some problems 😫
Incident Report for Lunar
Resolved
The issue has now been resolved by BEC.
Posted Dec 09, 2019 - 18:05 CET
Identified
The issue has been identified at BEC (Bankernes EDB Central) which is working hard to resolve the underlying issue.
Posted Dec 09, 2019 - 13:34 CET
Investigating
We are currently experiencing some problems with our Visa card - making it is impossible to use the card for some customers. 😔 💳 If you experience any faulty reservations on your card please contact us.
We're very sorry for the inconvenience. Stay tuned on this site for more information.
Posted Dec 09, 2019 - 12:20 CET
This incident affected: 💳 Visa Card Transactions Denmark.