Lunar Way Visa is not working
Incident Report for Lunar Way
Resolved
This incident has now been resolved.
Posted 3 months ago. Apr 10, 2019 - 16:12 CEST
Update
Everything seems to be working again 🙏
Posted 3 months ago. Apr 10, 2019 - 12:59 CEST
Investigating
Our Visa card is currently not working. We are so sorry!
We are doing all we can to identify the problem.

We'll keep you updated, we promise 🙏
Posted 3 months ago. Apr 10, 2019 - 12:40 CEST
This incident affected: 💳 Card Transactions.