Card transactions
Incident Report for Lunar Way
Resolved
BEC fixed their technical issue and everything is up and running smooth again. Thank you for your patience 🙏
Posted 10 months ago. Jan 16, 2018 - 11:07 CET
Identified
BEC is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
BEC is still experiencing technical problems. We're in touch - and they're currently working on a solution to fix the problem.
Posted 10 months ago. Jan 16, 2018 - 11:00 CET