BEC is currently experiencing technical problems
Incident Report for Lunar Way
Resolved
Everything looks back to normal. Sorry for all the trouble 🙏
Posted about 2 months ago. Jul 26, 2019 - 03:10 CEST
Investigating
We are experiencing problems at the moment 😩

Unfortunately we have not identified the problem yet but promise you to keep chasing a solution. We'll keep you updated!
Posted about 2 months ago. Jul 26, 2019 - 02:55 CEST
This incident affected: 💸 Payments (🇩🇰 Payments Denmark).