Mastercard issues
Incident Report for Lunar Way
Resolved
Mastercard should have resolved their network issues. Thank you for your patience 🙏
Posted about 1 year ago. Jul 12, 2018 - 22:39 CEST
Investigating
Mastercard is currently experiencing technical problems. This may affect your Travel Card transactions. We will follow the situation closely and keep you updated.
Posted about 1 year ago. Jul 12, 2018 - 20:46 CEST
This incident affected: 💳 Prepaid Card (✈️ Travel Card).