Card and transfers not working optimally 😟
Incident Report for Lunar
Resolved
BEC is up and running again. All problems have been fixed and we're ready to support you again! Thank you for your patience.
Posted Aug 17, 2018 - 17:14 CEST
Investigating
BEC is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated. 🙏
Posted Aug 17, 2018 - 15:32 CEST
This incident affected: 💸 Payments (🇩🇰 Payments Denmark) and 💳 Visa Card Transactions Denmark.