TopUp Errors
Incident Report for Lunar Way
Resolved
Everything seems to be back to normal 🙌
Posted 4 months ago. Jul 12, 2018 - 14:01 CEST
Investigating
We are currently investigating technical issues regarding TopUp. We will keep you updated 👍
Posted 4 months ago. Jul 12, 2018 - 13:16 CEST
This incident affected: ⚡️ Top-up.