Our Mastercard is down 😭
Incident Report for Lunar
Resolved
Everything should be back to normal - go swipe that card πŸ’Έ
Posted Aug 15, 2019 - 11:03 CEST
Monitoring
The problem has been solved and we are keeping an eye on everything. πŸ‘€πŸ€ž
Posted Aug 15, 2019 - 10:36 CEST
Investigating
Unfortunately, it's not possible to use your Mastercard at the moment πŸ’³ We apologize for the inconvenience. We will keep posting information on this site.
Posted Aug 15, 2019 - 10:01 CEST
This incident affected: πŸ’³ Prepaid Card (πŸ’Ό Business Card Transactions, πŸ‡ΈπŸ‡ͺ Card Transactions Sweden, πŸ‡³πŸ‡΄ Card Transactions Norway).