πŸ‡¬πŸ‡§ Our Mastercard is down 😭
Incident Report for Lunar
Resolved
Everything is back to normal - go swipe that card πŸ’Έ
Posted Nov 13, 2019 - 19:35 CET
Monitoring
The problem has been solved and we are keeping an eye on everything. πŸ‘€πŸ€ž
Posted Nov 13, 2019 - 16:38 CET
Investigating
Unfortunately, it's not possible to use your Mastercard at the moment πŸ’³ We apologize for the inconvenience. We will keep posting information on this site.
Posted Nov 13, 2019 - 16:19 CET
This incident affected: πŸ’³ Prepaid Card (✈️ Travel Card, πŸ’Ό Business Card Transactions, πŸ‡ΈπŸ‡ͺ Card Transactions Sweden, πŸ‡³πŸ‡΄ Card Transactions Norway).