Problem with currencies
Incident Report for Lunar
Resolved
We successfully implemented a fix. Everything should work as normal again.
Posted Jun 29, 2019 - 20:51 CEST
Update
We are still working with our partner to find a solution to the problem 🙏 Unfortunately we have no estimate as to when the issue will be resolved. We will keep updating this page every few hours.
Posted Jun 29, 2019 - 18:05 CEST
Update
There are still problems with currency conversions. We are still working with our partner to find a solution to the problem 🙏
Posted Jun 29, 2019 - 15:48 CEST
Investigating
We are getting reports of problems with currency conversion. We are working with our partner to find a solution to the problem 🙏
Posted Jun 29, 2019 - 13:19 CEST
This incident affected: 💳 Prepaid Card (✈️ Travel Card) and ⚡️ Top-up.