Lunar Way DK transfers and payments
Incident Report for Lunar Way
Resolved
It looks stable. Sorry four your troubles. 🙏
Posted 8 days ago. Apr 14, 2019 - 07:33 CEST
Monitoring
It looks like BEC is responding to. We will continue to monitor the situation closely.
Posted 8 days ago. Apr 14, 2019 - 07:28 CEST
Investigating
BEC is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
Posted 8 days ago. Apr 14, 2019 - 06:20 CEST
This incident affected: 💳 Card Transactions, 💸 Payments, and 🌴 Goals.