BEC is currently experiencing technical problems
Incident Report for Lunar
Resolved
BEC fixed their technical issue and is up and running smooth again. Thank you for your patience.
Posted Aug 22, 2018 - 07:17 CEST
Investigating
BEC is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
Posted Aug 22, 2018 - 06:51 CEST
This incident affected: 💳 Prepaid Card (✈️ Travel Card), 💸 Payments (🇩🇰 Payments Denmark), and ⚡️ Top-up.