Chat function is down
Incident Report for Lunar Way
Resolved
We're back - hit us 😃👊
Posted 3 months ago. Aug 21, 2018 - 12:52 CEST
Identified
Most of our users are having difficulties reaching us by chat at the moment - and we can't answer the few who gets a message through. Please give us a call instead: 70 60 54 54 🤗
Posted 3 months ago. Aug 21, 2018 - 12:45 CEST
This incident affected: 🙎 Support Chat.