Delayed Transfers
Incident Report for Lunar Way
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 10, 2019 - 22:37 CEST
Update
Everything looks like it's back to normal 🙏
Posted 3 months ago. Apr 10, 2019 - 22:37 CEST
Update
We are continuing to investigate this issue.
Posted 3 months ago. Apr 10, 2019 - 22:02 CEST
Update
We still see delayed transfers for some users.

We will keep you updated here as we know more.
Posted 3 months ago. Apr 10, 2019 - 21:59 CEST
Investigating
Some users are currently experiencing delayed transfers. We are currently investigating the problem.
Posted 3 months ago. Apr 10, 2019 - 21:22 CEST
This incident affected: 💳 Card Transactions and 💸 Payments.