Travel Card
Incident Report for Lunar Way
Resolved
Everything is back to normal 🙌
Posted 11 months ago. Dec 28, 2017 - 16:08 CET
Identified
Sorry guys! 😓 At the moment it is not possible to deposit, withdraw and exchange on your account.

Your card is working perfectly and we are working on a solution. Hang tight 🙏
Posted 11 months ago. Dec 28, 2017 - 14:28 CET