Card transactions
Incident Report for Lunar Way
Resolved
BEC fixed their technical issue and everything is up and running smooth again. Thank you for your patience 🙏
Posted 5 months ago. Jul 05, 2018 - 11:46 CEST
Investigating
BEC is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
Posted 5 months ago. Jul 05, 2018 - 11:16 CEST
This incident affected: 💳 Card Transactions.