Our Mastercard is down 😭
Incident Report for Lunar Way
Resolved
Everything is back to normal - go swipe that card πŸ’Έ
Posted 10 days ago. Sep 11, 2019 - 14:47 CEST
Investigating
Unfortunately, it's not possible to use your Mastercard at the moment πŸ’³ We apologize for the inconvenience. We will keep posting information on this site.
Posted 10 days ago. Sep 11, 2019 - 14:23 CEST
This incident affected: πŸ’³ Prepaid Card (πŸ’Ό Business Card Transactions, πŸ‡ΈπŸ‡ͺ Card Transactions Sweden, πŸ‡³πŸ‡΄ Card Transactions Norway).