Our Visa card is not working 😫
Incident Report for Lunar
Resolved
YAY! Everything is back to normal - happy shopping guys. 💸
Posted Dec 05, 2019 - 11:32 CET
Investigating
We are currently experiencing some problems with our Visa card - making it is impossible to use the card. 😔 💳
We're very sorry for the inconvenience. Stay tuned on this site for more information.
Posted Dec 05, 2019 - 09:16 CET
This incident affected: 💳 Visa Card Transactions Denmark.