Travel Card is not working
Incident Report for Lunar Way
Resolved
Everything should now be back to normal 😊
We are sorry if this outage inconvenienced you in any way 🙏
Posted 2 months ago. Feb 20, 2019 - 21:59 CET
Update
We are continuing to investigate this issue.
Posted 2 months ago. Feb 19, 2019 - 22:49 CET
Investigating
Our Travel Card users may experience issues with their card right now.
We are trying to find and fix the issue as soon as possible. 🙏
We are so sorry guys 😢
Posted 2 months ago. Feb 19, 2019 - 21:05 CET
This incident affected: ✈️ Travel Card.