Support chat issues
Incident Report for Lunar Way
Resolved
We are back in business 🙌 It should now be possible to get hold of our great supporters again. Have a nice day 😊
Posted 3 months ago. Jun 19, 2019 - 10:37 CEST
Identified
Our support systems is currently experiencing technical issues. The problem has been identified and our partner is working hard to resolve the issue 🙏
Posted 3 months ago. Jun 19, 2019 - 10:15 CEST
This incident affected: 🙎 Support Chat.