Lunar Way Visa is not working 😩
Incident Report for Lunar Way
Resolved
Everything seems to be working again 🙏
Posted 14 days ago. Apr 08, 2019 - 20:50 CEST
Investigating
Our Visa card is not working at the moment, so so sorry!
We just heard so we are doing all we can to identify the problem.

Promise: we'll keep you updated 🙏
Posted 14 days ago. Apr 08, 2019 - 20:19 CEST
This incident affected: 💳 Card Transactions.