Reservations may occur as a result of a failed card transaction
Incident Report for Lunar Way
Resolved
We are no longer receiving new cases for this issue. We'll continue to look into the cases to ensure our users are refunded correctly as fast as possible.
Posted 20 days ago. Nov 23, 2018 - 20:52 CET
Investigating
We are currently experiencing misleading reservations of transactions on the card, due to a rejection of the use of the card.

We are in the process of finding the reason for this.

The misleading reservations will, of course, be removed again as soon as possible.
Posted 20 days ago. Nov 23, 2018 - 17:30 CET
This incident affected: 💳 Card Transactions.