Problem with express transfers
Incident Report for Lunar Way
Resolved
The issue has been resolved. Express transfers are working again.
Posted 7 months ago. Nov 21, 2018 - 08:13 CET
Monitoring
We are still keeping an eye on the issue, but unfortunately no news 🙏
Posted 7 months ago. Nov 20, 2018 - 14:22 CET
Identified
BEC is currently experiencing technical problems, that is effecting your express transfer.
Transfers made as express transfers will not show up immediately.
Unfortunately we do not have any influence on this, but we will follow the situation closely and keep you updated.
Posted 7 months ago. Nov 20, 2018 - 10:22 CET
This incident affected: 💸 Payments.