BEC is currently experiencing technical problems
Incident Report for Lunar Way
Resolved
BEC is up and running again. All problems have been fixed and we're ready to support you again! Thank you for your patience.
Posted 8 months ago. Mar 11, 2018 - 06:33 CET
Identified
BEC is still experiencing technical problems. We're in touch - and they're currently working on a solution to fix the problem. We expect services to be working again at 6:00.
Posted 8 months ago. Mar 11, 2018 - 03:10 CET
Investigating
BEC is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
Posted 8 months ago. Mar 11, 2018 - 02:28 CET