Processing card transactions
Incident Report for Lunar Way
Resolved
Everything should now be back to normal πŸ™Œ We apologize for any inconvenience caused.
Posted 21 days ago. Aug 02, 2019 - 12:52 CEST
Investigating
We are currently investigating an issue affecting processing card transactions. We will keep you updated πŸ™
Posted 21 days ago. Aug 02, 2019 - 12:36 CEST
This incident affected: πŸ’³ Prepaid Card (✈️ Travel Card, πŸ’Ό Business Card Transactions, πŸ‡ΈπŸ‡ͺ Card Transactions Sweden, πŸ‡³πŸ‡΄ Card Transactions Norway).