Our Travel Card is experiencing problems 😭
Incident Report for Lunar
Resolved
Everything is back to normal - go swipe that card 💸
Posted 10 days ago. Oct 07, 2019 - 15:18 CEST
Investigating
One of our partners is experiencing problems, which means you may not be able to use your Travel Card at the moment. However, you can still use your Black Card 💳 We apologize for the inconvenience. We will keep posting information on this site. 🙂
Posted 10 days ago. Oct 07, 2019 - 15:01 CEST
This incident affected: 💳 Prepaid Card (✈️ Travel Card).