Everything is down at the moment 😢
Incident Report for Lunar Way
Resolved
4 hectic minutes 😳
Everything is back to normal 🙏
Posted 7 months ago. Apr 13, 2018 - 14:39 CEST
Identified
BEC (our data central) is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. It affects our systems as well, so unfortunately we can't be helpfull with transfers in this situation 😔
We will follow the situation closely and keep you updated.
Posted 7 months ago. Apr 13, 2018 - 14:32 CEST