Cards is effected πŸ˜•
Incident Report for Lunar Way
Resolved
Everything should be back to normal - happy shopping πŸ’ΈπŸ˜‰
Posted 3 months ago. Aug 31, 2018 - 20:05 CEST
Identified
Due to the issue with payment clearing this morning, your card can be affected. NETS has announced that every third transaction will be affected. Please try again πŸ™

We're sorry for the inconvenience this may have πŸ˜•
Posted 3 months ago. Aug 31, 2018 - 09:11 CEST
This incident affected: πŸ’³ Card Transactions.