Our Visa card and transfers are not working 😫
Incident Report for Lunar
Resolved
The problem has been resolved. 🎉
Posted Feb 05, 2020 - 15:25 CET
Investigating
We are currently experiencing some problems with our Visa card - you might not be able to use the card. 😔 💳
We're very sorry for the inconvenience. Stay tuned on this site for more information.
Transfer are also intermittently unusable.
Posted Feb 05, 2020 - 14:52 CET
This incident affected: 💸 Payments (🇩🇰 Payments Denmark) and 💳 Visa Card Transactions Denmark, 📄 Pay My Bill Denmark, ⚡️ Top-up.