Problems with Visa card transactions
Incident Report for Lunar Way
Resolved
This incident has been resolved.
Posted 20 days ago. Nov 23, 2018 - 16:43 CET
Update
The issue seems to have been solved. We'll create a new issue if there is any new developments.
Posted 20 days ago. Nov 23, 2018 - 16:42 CET
Update
We are so sorry that you guys' cards are not working 😓
Most of our users have had success when paying with MobilePay. Perhaps you could try that 🤷‍♀️
Posted 20 days ago. Nov 23, 2018 - 16:06 CET
Investigating
Nets is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
Posted 20 days ago. Nov 23, 2018 - 15:46 CET
This incident affected: 💳 Card Transactions.