Problems with transfers
Incident Report for Lunar Way
Resolved
Everything seems to be back to normal 🤗🙌
Posted 11 months ago. Jun 17, 2018 - 06:09 CEST
Update
We are continuing to monitor for any further issues.
Posted 11 months ago. Jun 17, 2018 - 03:29 CEST
Monitoring
BEC is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
Posted 11 months ago. Jun 17, 2018 - 03:22 CEST
Investigating
We are currently investigating this issue.
Posted 11 months ago. Jun 17, 2018 - 03:03 CEST
This incident affected: 💳 Card Transactions, 💸 Payments, and ⚡️ Top-up.