Our Mastercard is experiencing problems 😭
Incident Report for Lunar
Resolved
Everything is back to normal - go swipe that card πŸ’Έ
Posted 10 days ago. Oct 07, 2019 - 15:18 CEST
Investigating
One of our partners is experiencing problems, which means you may not be able to use your Mastercard at the moment. We apologize for the inconvenience. We will keep posting information on this site. πŸ™‚
Posted 10 days ago. Oct 07, 2019 - 15:02 CEST
This incident affected: πŸ’³ Prepaid Card (πŸ’Ό Business Card Transactions, πŸ‡ΈπŸ‡ͺ Card Transactions Sweden, πŸ‡³πŸ‡΄ Card Transactions Norway).