Currency Conversion problems
Incident Report for Lunar
Resolved
Our partner has informed us that a fix has been implemented. Everything should now be working again - sorry about the disruption 😊
Posted Jun 24, 2019 - 14:56 CEST
Identified
Our partner has identified a network issue affecting some users. They are working on a solution.
Posted Jun 24, 2019 - 14:15 CEST
Investigating
We are currently seeing an increased amount of errors on functionality tied to currency conversion. This will affect TopUp and Travel Card. We are investigating the issue 🙏
Posted Jun 24, 2019 - 13:36 CEST
This incident affected: 💳 Prepaid Card (✈️ Travel Card) and ⚡️ Top-up.