Lunar Way Visa is not working 😩
Incident Report for Lunar Way
Resolved
The incident has been resolved.
Posted 4 months ago. Jun 07, 2019 - 14:32 CEST
Identified
BEC is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
New transactions might also be delayed showing up in the app.
Posted 4 months ago. Jun 07, 2019 - 13:12 CEST
Investigating
Nets is currently experiencing technical problems. This may affect your transactions and card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
Posted 4 months ago. Jun 07, 2019 - 12:42 CEST
This incident affected: 📱 Lunar Way App and 💳 Visa Card Transactions Denmark.