Problem updating Invest Positions
Incident Report for Lunar
Resolved
Everthing should now be back to normal. Happy trading! 😊
Posted Feb 16, 2020 - 17:34 CET
Investigating
We are currently investigating an issue with positions not being updated. This means any positions you currently own may not show correct information at the momement.
Posted Feb 16, 2020 - 17:21 CET
This incident affected: 📈 Invest Denmark.