Card Transctions is down
Incident Report for Lunar Way
Resolved
Nets is all functional again 🙌
Posted 2 months ago. Oct 01, 2017 - 14:17 CEST
Monitoring
Nets is currently experiencing technical problems. This affect your card activity, but unfortunately we do not have any influence on this. We will follow the situation closely and keep you updated.
Posted 2 months ago. Oct 01, 2017 - 13:50 CEST