Payments is down
Incident Report for Lunar Way
Resolved
Everything is working again.
We still have some leftovers from the problem, so if you have made a Top-Up Wednesday they will be at your account Thursday. Please contact our support if you have any questions 🙏
Posted 8 months ago. Mar 21, 2018 - 16:58 CET
Monitoring
As long as we have these difficulties you are very welcome to contact our support, if you need any help transferring your money or other inquiries 🤳
Posted 8 months ago. Mar 21, 2018 - 13:12 CET
Update
We're so so sorry but we have to disable some of our features. We're working as hard as we can to fix the problem 🙏
Posted 8 months ago. Mar 21, 2018 - 12:09 CET
Identified
We have identified the problem and we are working with our businesspartners to solve the problem 👍
Posted 8 months ago. Mar 21, 2018 - 10:39 CET
Investigating
We're experiencing problems with payments at the moment. We're working as fast as we can to detect and solve the problem 🙏
Posted 8 months ago. Mar 21, 2018 - 09:19 CET