Transfers unavailable 😔
Incident Report for Lunar Way
Resolved
Transfers is now up running again 👍
Thank you for your patience 🙏
If you have any questions, give our support a call or reach them by the app.
Posted 7 months ago. Apr 20, 2018 - 18:20 CEST
Investigating
Unfortunately it is not possible to transfer or receive money from some banks at the moment.
We're working on identifying which banks are affected by the issue.
We'll keep you updated.

If you need to make a transfer right now, give our support a call or reach them by the app, then they will make the transfer for you 🙏
Posted 7 months ago. Apr 20, 2018 - 15:36 CEST